Back to overview
Downtime

Cloud unstable

Nov 14 at 08:59am CET
Affected services
Web
Tablet Connection

Resolved
Nov 14 at 09:55am CET

Remote support of machines still affected. We are working on a solution

Created
Nov 14 at 08:59am CET

Cloud is unstable at the moment. We are working on a fix.
Remember tablets will continue to work is offline mode and sync when cloud is running stable again.